
Configuring Yate's Appearance

This document describes how to use configure the Yate's appearance. Primarily this pertains to the main window but
there is a degree of configurability for database files as well.

All screenshots in this document were taken on macOS Sequoia.
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Main Window Layout

The main window supports three working areas. The File Browser is an optional Finder like view into a single folder.
The File List area presents a list of loaded files with configurable columns. The Edit Panel area displays panels
containing fields where you can edit metadata.

The display of the File Browser is optional. This is controlled by the Hide / Show File Browser menu item on the
Window menu.

The Edit Panel area can be displayed as part of the main window or detached into a separate window. This is controlled
by the Window menu's Detach / Attach Edit Panels menu items.

Each of the three potential work areas on the main window has an assigned position. You can arrange them in any order
to meet your preferences. This is done via the Window menu's Window Panel Layout submenu.
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The submenu displays each of the possible layouts. Remember that these layouts describe the position of the three
working areas when displayed. If the edit panels are detached, they will simply not appear in the main window. When
reattached, they will go back to their defined location.

When the Edit Panels are detached, they appear in their own window which can be minimized or closed. Clicking on
the dock icon will cause a closed Edit Panel window to be redisplayed. Note that the main window and a detached Edit
Panels window are treated as if they are one window. Sheets (popup panels) are displayed on whichever window has the
focus and both windows are disabled whenever one is disabled.

Back to Table of Contents
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Vertically Sizing the Main Window

The main window can be resized to be smaller than the minimum vertical size of an Edit Panel. When this is done you
can scroll the edit panel by doing so by scrolling any part of the panel except in a multi line text field.

The following screenshot shows the main window resized such that the entire Info Editing Panel cannot be entirely
displayed. The window also has a non default layout for the three work areas.

Back to Table of Contents
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The File Browser

On the File Browser's context menu you can configure which content is displayed and how by using the items on the
View Options submenu.

Also on the context menu you can pin folders for fast access.

The Information Area at sometimes displayed at the bottom of the File Browser is configurable. It might be obvious but
the Information Area is not displayed unless the File Browser is displayed.

You can controll the display of the information area by means of the Window menu's Enable/Disable File Browser
Information Area item.

You control what content optionally gets displayed by means of the Window menu's Display Artwork/Audio Info in
File Browser Information Area menu item.

When displaying audio information and a single file is selected in the file list area, the display will be similar to the
following screenshot:

When audio information is displayed and a Stem file (stem.mp4) is selected, double clicking in the panel will display
the stem metadata. If a WAV file is selected and it has BEXT Metadata metadata, double clicking will display the
metadata.

A popup version of the audio information panel can be displayed at any time by right clicking on a file and selecting
Audio Information from the file list area's context menu or by selecting a single file and doing a View>Audio
Information.

When displaying artwork and all selected file's have the same default artwork item, the display will be similar to the
following screenshot:
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The image has a context menu item named Get Info. Selecting the menu item will display a panel presenting the
image's properties. The property panel can be dismissed by the Escape key. Double clicking on the image will display a
full artwork edit panel. The choice of which panel to display is made as follows:

If the Artwork edit panel is mapped to an edit panel preset button, it
If a custom edit panel containing a full artwork display is mapped to an edit panel preset button, it will be
displayed.
The Artwork edit panel will be displayed on an empty edit panel preset button, if available.
The Artwork edit panel will be displayed on the last edit panel preset button.

Back to Table of Contents
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Configuring the Toolbar Display

The toolbar can be displayed or hidden by means of the Window menu's Hide/Show Toolbar item.

How the toolbar is displayed and the size of the icons depends on the version of macOS which is running. While
Customize Toolbar can be started from the Window menu, it is preferable to enter the customization process by right
clicking on the toolbar. The displayed menu may have additional settings depending on the version of macOS and
whether the Title bar is displayed. These may include selecting a large or small icon display and the display of
descriptive text under icons.

On newer versions of macOS, Yate does not automatically display the Title Bar as it differs from earlier OS versions
where it was a completely separate area at the top of a window. On newer OS versions when a Title Bar is not
displayed, icons are always displayed small and without text. If you want larger icons or text under an icon, you will
have to display the Title Bar by the Window menu's Show Title Bar menu item. All previous screenshots did not have
the Title Bar displayed. The following screenshot has the Title Bar displayed and displays text under each icon:

Notice that Yate is now displayed to the left of the window banner and that all toolbar items have been shifted right. The
Flexible Space toolbar item may not do what you expect in this scenario depending on the OS version. Remember that
the size chosen for the toolbar icons is made by the system. On newer OS versions, there is no way to manually select
large or small icons.

As far as changing the content of the toolbar, do a Customize Toolbar and drag items to the toolbar or out of the
toolbar.

Back to Table of Contents
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Selecting Which Columns are Displayed in the File List Area

Selecting which columns are displayed is performed in a variety of ways. The first is to right click on any column
header and select the desired columns one at a time at the bottom of the displayed menu. The names of columns already
displayed are preceded by a checkmark.

To configure more than one column at a time select the Manage Displayed Columns menu item. A panel such as in the
following screenshot will be displayed.
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If you are consistently going to use the above method, you can hide the column list on the context menu by selecting
Hide Column List.

Back to Table of Contents
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Saving Column Layouts

You can save and reload any number of saved column layouts. A saved column layout also attempts to retain the width
of each column. You can save and restore column layouts by right clicking on any column header and selecting Saved
Column Layouts.

The displayed submenu has Manage at the top and any previously saved column layout at the bottom. Clicking on a
previously saved layout, will cause it to be displayed. Manage will display a panel as follows:

To save a copy of the current column layout, hit the + button. To delete one or more saved column layouts, select them
and ht the - button. To update the definition of a saved column layout to the current column layout, select it and hit the
up arrow button.

Back to Table of Contents

10



Autosizing Columns

Columns can be autosized to their full width or to a limited width. When resizing to full width the maximum size of a
column will be 2000 points. When limiting the size it will be restricted to a maximum of 300 points.

Right click anywhere on a column header (or on a specific column) and select Auto Size.

All menu items which do not contain All work on the column which was clicked. Note that the Downsize functions
limit the size of columns which might be wider than a column which was limited.

You can automatically do an Autosize Limited on all columns after loading files. To do so, enable the Settings - File
List - Autosize column widths after loading files option. Depending on which version of Yate you first installed, the
setting may or may not be enabled.

Back to Table of Contents
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Configuring Edit Panel Preset Buttons

There are ten Edit Panel preset buttons. Each button makes it easy to access with a built in edit panel or a custom
defined edit panel.

The above screenshot displays the out of the box layout. You can rearrange the buttons by dragging a button to a new
position. The only special button is the tenth, initially empty, button. This button is used by various functionality which
automatically displays a specific edit panel when there is no available empty preset to display the button.

To change the edit panel referenced by a preset button, you would typically right click on the button and select the panel
you want to display.

Yate has a lot of edit panels and there may be some that you have no interest in. These panels can be hidden from the
menu by selecting Manage Hidden Edit Panels from the context menu. On the displayed window you can specify
which panels you want to hide. Note than when a panel is hidden it can still be accessed on the context menu's Hidden
Edit Panels submenu.

You can save different named sets of edit panel preset button layouts. On the context menu, click on Saved Preset
Button Layouts. The displayed menu lists the names of all saved sets you have created and has a Manage item. The
Manage item works exactly the same as the Manage item for saved column configuration layouts.

One of the most powerful features in Yate is the ability for you to define your own custom edit panels. This
functionality is defined in The Custom Panel Editor.

Back to Table of Contents

12

https://2manyrobots.com/YateResources/InAppHelp/CustomPanelEditor.html


Other File List Appearance Settings

Settings - File List has a number of options which configure the appearance of the file list.

You can configure the background and grid styles to be used for the table. You can also configure the status bar to
display abbreviated paths. You can choose a toolbar set.

You can configure how the Year field displays content when more than just the year is available. When set to Never,
yyyy-mm-dd fields will be displayed as opposed to simply yyyy.

You can configure which items appear on the file list's context menu and where. Use the context menu's Configure
button on the Settings - File List panel.

It is a good idea, to display the help for Settings - File List as most settings are pertinent to a large number of users.

Back to Table of Contents
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Font Sizes

Most Yate windows and multi line text fields can have their font size changed via Font>Bigger (⌘+) and Font> Smaller
(⌘-).

The size of text on the status bar can be changed by Font>Smaller|Larger Text on Status Bars.

Back to Table of Contents
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Default Database Appearance

Databases are used in Yate and many of the supplied resource actions. As multiple database files can be created and can
be open at any given time, you can configure the appearance of newly created databases in Settings - Database -
Appearance.

These settings include The background style/colour and an initial choice of font size. You can also configure how
certain column types can be graphically represented.

The size of text on the status bar can be changed by Font>Smaller|Larger Text on Status Bars.

Back to Table of Contents
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The Log Viewer

The Log Viewer is extensively used in Yate. You can change the background colour via the viewer's context menu. You
can also change the font size as described in Font Sizes.

Back to Table of Contents
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Alert Panels

Starting with Big Sur, the OS displays iPad like vertical alerts with centered text. This style does not work well for
many Yate alerts as the alerts may contain file paths.

You can tell Yate to display an alternate alert style in Settings - General Basic by enabling the Use alternate alert
style setting. These alerts display similar to pre Big Sur alerts ... ie. a wider panel where the text is not centered. You
can also enable the Larger text setting to use somewhat larger font sizes when displaying the alert. These settings are
ignored on OS versions prior to 10.12.

Back to Table of Contents
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History

Release 1.0   2025-02-19
First general release.
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